Home > Información > Compatibilizar complementos para que funcionen con cualquier versión de Firefox

Compatibilizar complementos para que funcionen con cualquier versión de Firefox


Uno de los problemas más comunes que solemos tener los usuarios de Firefox es que, al actualizar la versión del navegador, algunos complementos se vuelven incompatibles, lo que en algunos casos puede llegar a resultar motivo suficiente como para no realizar la descarga correspondiente.

Por eso, hoy publicaremos una pequeña guía para hacer compatibles todas las extensiones con cualquier versión de Firefox. Es que, en general, muchas extensiones de Firefox trabajan perfecto con versiones nuevas, pero simplemente tienen un problema de compatibilidad que involucra tan sólo “un número” en toda la configuración del plugin.

Veamos en una imágen que explicita mejor a qué me refiero:

compatibilidad firefox complementos

“Hackeando” el archivo XPI

Para este proceso, tendremos que descargar manualmente el complemento a nuestro disco duro. Para hacerlo, tendremos que hacer click derecho en el botón de “Instalar” y seleccionar “Guardar como”. Después de hacerlo, comenzaremos a trucar la extensión.

compatibilidad firefox complementos

Para el ejemplo utilizaré la extensión “Yoono”. Cuando descargamos el archivo al ordenador, es recomendable hacerlo en una carpeta nueva, para luego guardar los archivos del zip allí, del mismo modo que haríamos con cualquier otro archivo de ese tipo.

Una vez realizado ese paso, tendremos que concentrarnos en un solo fichero: “Install.rdf” (es recomendable copiar el archivo y pegarlo en otro lugar, como para tener la versión original del mismo ante cualquier error)

compatibilizar complementos de firefox para cualquier version

Abrimos el archivo en el “Bloc de Notas”, para poder cambiar el número de “maxVersion” por uno más alto. Pondré “3.7”, para que todas las versiones de Firefox sean compatibles.

compatibilizar extensiones firefox

Después de hacerlo, simplemente cerramos y guardamos sin cambiar el nombre del archivo, claro está. Ahora, para que la extensión funcione correctamente, simplemente creamos otro ZIP, cambiando el nombre y la extensión del .zip por un nombre aleatorio, seguido de “.XPI”

compatibilizar extensiones firefox tutorial

Después de hacerlo, simplemente abrimos el navegador y la carpeta donde guardamos el archivo, y lo “llevamos” desde la carpeta a Firefox como muestro en la imágen siguiente:

extensiones compatibles con cualquier version de firefox

Una vez que completamos ese paso, tan sólo tendremos que esperar a que Firefox reconozca la carpeta y nos pregunte si deseamos instalar el complemento. Lo único que resta es clickear en “Instalar ahora” y listo, ya podremos utilizar la extensión con cualquier versión de Firefox.

extensiones compatibles con cualquier version de firefox

Vía: HowToGeek

1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...


Dejá un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *